ようこそゲストさん! >>  ユーザ名 パスワード   新規登録パスワード忘れtwitterでつぶやく
  [フォーラム] [ニュース] [ブログ] [リンク集] [XOOPS関連RSS] [うさぎの辞典] [ダウンロード] [このサイトについて]
Login by facebook
Login by twitter
検索
マンガ
メインメニュー
ログイン
ユーザー名:

パスワード:


パスワード紛失

新規登録
twitter
XOOPS Cubeを使おう♪
インストール編
タイトルとテーマを変更しよう
ユーザー情報を変えよう
モジュールを使おうpico編
モジュールを使おう d3pipes編
モジュールを使おう bulletin編
モジュールアップデートをしよう
HDをアップデートする
ユーザーさんマニュアル
インストール編 旧
携帯サイト
うさぎにもできるXOOPS Cube入門♪ 携帯サイト うさぎにもできるXOOPS Cube入門♪ 携帯サイト
Go iPhone!

9.インストール 16〜22

インストール編  >  9.インストール 16〜22
インストール画面 16/22

おめでとうございます!インストール第1ステップが完了しました。
しかし、このあとのステップをもうちょっとだけやらないと実際に使えるようにはなりません。
画面を閉じずに第2ステップの方法をじっくりと読み、[次へ]ボタンを押します。

インストール画面 17/22

管理者のログイン画面です。必要な情報をメモ!でメモをしておいた管理者ユーザ名とパスワードを入れ、[ログイン]ボタンを押します。

インストール画面 18/22

モジュール選択画面です。導入推奨モジュールにはあらかじめチェックが入っています。ここではすぐにサイト作りができるように 選択導入可能モジュールの中から

d3blog (ブログモジュール)
d3forum (フォーラムモジュール)
d3pipes (RSSパイプモジュール)
hdpoll (投票モジュール)
pico (静的コンテンツモジュール)

を導入してみます(一例ですので特に同じようにしなくても、お好みのモジュールを選択していただいて大丈夫です)。これら5つにもチェックを入れてから[インストール]ボタンを押します。
ここでインストールしなくても、既にファイルがアップロードされているので管理画面からこれらのモジュールをインストールすることも可能です。


インストール画面 19/22

XOOPS Cube本体のインストール、xoops_trust_path、モジュールの設置が終了して確認画面が表示されます。
画面にあるようにセキュリティのため、installフォルダをftpソフトなどで削除します。削除が終わったら、ブラウザを再読込してください。

インストール画面 20/22

やっとXOOPS Cubeの表画面!が出ました。インストールの途中で指定したテーマが使われています。
あともう一カ所、最後の設定をします。
画面のユーザーメニューにある管理者メニューをクリックして管理者画面に入ります。

インストール画面 21/22

管理画面にはいるとmainfile.phpに関する警告が表示されています。書いてあるとおりにmainfile.phpの属性をftpソフトなどで書き込み不可(755など)に変更してください。変更後、ブラウザの再読込を行います。

インストール画面 22/22

再読込をすると先ほどの警告文が消えた画面になります。
これでインストールとセキュリティ上の設定がすべて終わりました。

モジュールの設定やコンテンツの入力により、より自分らしいサイトにカスタマイズしていきましょう♪

プリンタ用画面
前
8.インストール 11〜15
カテゴリートップ
インストール編

コメント一覧

moegiiro  投稿日時 2010-12-6 13:57
jeanbartさん

> として、xoops_trust_pathフォルダの中にアップロードしました
root_path に置くモノだと思うんですが。。

個人的には register_globals on のサーバーはコワくて使えません。
自分のところを適切に設定しても、他所のところがそのままだったら
と思うと。。。
mika  投稿日時 2010-12-6 13:16
こんにちは。jeanbartさん。

引用:

jeanbartさんは書きました:
こんにちは

いくつか同じ質問をされている方がいて、何通りか解決策を試みたのですがうまくいかないのでお聞きします。アドバイスよろしくおねがいいたします。

状況:
リモートサーバーに無事インストール成功。
管理者IDでログイン可能。
しかし管理者用メニューをクリックすると
「WARNING: php.ini parameter "register_globals" is set to "on".」のエラーメッセージがでたため、以下のことを試みました。

1.
php:iniのセッティングを変えようとリモートサーバーにinfo.phpを配置し、php.iniの場所を確認したのですがシェアサーバーなのかアクセスできる場所にありません。
(マスターバリュー・ロコバリューともONになっていました)ちなみに自分のpublic_htmlフォルダにはphp.iniはありません。

2.
.htaccessファイルを作成し、中身を
order deny,allow
deny from all
php_flag register_globals off
php_flag display_errors off

として、xoops_trust_pathフォルダの中にアップロードしました(もともとここに.htaccessファイルが入ってましたので)。

2の結果:まったく同じで
「WARNING: php.ini parameter "register_globals" is set to "on".」のエラーメッセージがでました。

かなりがんばりましたが、お手上げに近い状態で困っています。
お手数をおかけしますが、どうすればよいのかご指導くださいませ。よろしくお願いいたします。


解決ではなくて、一応念のためなのですが。この辺のセッティングについてはサーバのポリシーのようなところが影響するようですのでサーバの管理をされている方に相談されるのが一番かと思われます。

レンタルサーバでしたらその会社に問い合わせるとかかと思います。

もうとっくに問い合わせされていたり、する場合は蛇足のメッセージになってしまって申し訳ないですが(^^;
jeanbart  投稿日時 2010-11-30 20:59
こんにちは

いくつか同じ質問をされている方がいて、何通りか解決策を試みたのですがうまくいかないのでお聞きします。アドバイスよろしくおねがいいたします。

状況:
リモートサーバーに無事インストール成功。
管理者IDでログイン可能。
しかし管理者用メニューをクリックすると
「WARNING: php.ini parameter "register_globals" is set to "on".」のエラーメッセージがでたため、以下のことを試みました。

1.
php:iniのセッティングを変えようとリモートサーバーにinfo.phpを配置し、php.iniの場所を確認したのですがシェアサーバーなのかアクセスできる場所にありません。
(マスターバリュー・ロコバリューともONになっていました)ちなみに自分のpublic_htmlフォルダにはphp.iniはありません。

2.
.htaccessファイルを作成し、中身を
order deny,allow
deny from all
php_flag register_globals off
php_flag display_errors off

として、xoops_trust_pathフォルダの中にアップロードしました(もともとここに.htaccessファイルが入ってましたので)。

2の結果:まったく同じで
「WARNING: php.ini parameter "register_globals" is set to "on".」のエラーメッセージがでました。

かなりがんばりましたが、お手上げに近い状態で困っています。
お手数をおかけしますが、どうすればよいのかご指導くださいませ。よろしくお願いいたします。
ant  投稿日時 2010-10-15 6:20
moegiiroさんありがとうございます。
ご指摘いただいた箇所を修正したら無事にアクセス可能になりました。
IPアドレスは現在は固定です。
アドバイスありがとうございます。
新しいモジュールを作るところまで行きたいのですが、
道のりは長そうです・・・
またお世話になります。
moegiiro  投稿日時 2010-10-14 21:52 | 最終変更
antさん

インストールディレクトリの mainfile.php 44行目あたり
 define('XOOPS_URL', 'http://localhost/xoops');
となっていると思います。
これを
 define('XOOPS_URL', 'http://***.***.***.***/xoops');
としてください。
たぶん、動くと思います(^^)
もちろんインストールマシンも
 http://***.***.***.***/xoops/ でアクセスしてくださいね。


ただ、、、
***.***.***.*** ってIPアドレスですよね?
インストールマシンのIPアドレスは固定されていますか?
もしDHCP(自動取得)でしたら、antさんの組織のネットワーク管理者に連絡して、
固定IPにしてもらうなどの設定も必要になります。
DHCPだとIPアドレスが変わるたびに mainfile.php も変更しなくちゃなりません。。

あとインストールモジュールの一般設定や、画像ファイルの保存URLの
FQDNも(この場合 localhostを***.***.***.***に)変更する必要があるかもしれません。
ant  投稿日時 2010-10-14 2:15
こちらの解説がとても参考なりました。
ありがとうございます。
初歩的な質問で申し訳ないのですが、
LAN内のPC上でXAMPP Windows
xampp-win32-1.7.1-installer.exeを導入した上に
hd_full_1_0_4をインストールしました。
インストールしたマシンからhttp://localhost/xoops
を叩くと正常にログイン画面が表示されて普通に使えるのですが、
LAN内の他のマシンから
http://***.***.***.***/xoops/
とアクセスすると、やはりログイン画面は現れるのですが、
文字だけでロゴや背景が表示されません・・・
その画面からユーザー名やパスワードを入力すると
http://localhost/xoops/install/index.phpや
http://localhost/xoops/user.php
に飛ばされてしまいます。
HTTP500内部サーバーエラーとなってしまいます。
他のマシンから使いたい場合はどうすればよいのでしょうか?
よろしければ問題点を教えてください。
mika  投稿日時 2010-9-30 9:44
おはようございます、tyoro0219さん。

引用:

tyoro0219さんは書きました:
すみません。kimiyamaさんと同じなのですが

インストールは、正常に終了するのですが
その後の、管理者IDでログインしようとしても、ログインできません。【ログイン情報が間違っています】とでます。

登録情報を
コピーペーストしても、間違えていると出るのですが
どうしたらよいですか?

パスワード忘れ、というリンクは出ていないでしょうか?そちらにメールアドレスを入れて送信すると仮のパスワードが送信されます。それを使ってログインできるようになります。

お試しください♪
mika  投稿日時 2010-9-17 10:39
moegiiroさん、おはようございます。

引用:

moegiiroさんは書きました:
なんか自己解決しちゃったみたいですよ。。
http://www.xugj.org/modules/QandA/index.php?topic_id=1830

このひとつ前の kmiyama さんもそうですけど、
「自己解決」したなら、なにが原因だったかを
「記録」してほしいですね。
後に続く人への 資産 になりますから。

とうことで kmiyama さん tyoro0219 さん
 なにが問題だったのか
 どう解決したのか
記録を残してくださいませ。

#セキュリティ対策ソフトかなぁ。。

あ〜、解決できたんですね〜良かった♪moegiiroさん教えてくれてありがとうございます。

もしも、何が原因だったか書いていただけると確かに助かりますー。なので、これ見られたら書いていただいたらうれしいです。とはいえ、解決できてよかったです。

わたしもよくやってしまうんですが唖然とするのが「絶対こうなはず!」と思っていて、その原因が自分の勘違いだったりするということ。なので〜、どんな些細な原因でも書いていただけると役に立ったりすることはあると思います。

わたしがその系でよくやっちゃうのはテキストにパスワードとか保存しておいてコピペするときになぜか前後に余計な空白も付いてきて、パスワードが違うといわれてしまうこと…(^^;。あ、わたし以外いないかな。
moegiiro  投稿日時 2010-9-16 22:30
なんか自己解決しちゃったみたいですよ。。
http://www.xugj.org/modules/QandA/index.php?topic_id=1830

このひとつ前の kmiyama さんもそうですけど、
「自己解決」したなら、なにが原因だったかを
「記録」してほしいですね。
後に続く人への 資産 になりますから。

とうことで kmiyama さん tyoro0219 さん
 なにが問題だったのか
 どう解決したのか
記録を残してくださいませ。

#セキュリティ対策ソフトかなぁ。。
mika  投稿日時 2010-9-16 18:19
こんにちは、kimiyamaさん。

引用:

tyoro0219さんは書きました:
すみません。kimiyamaさんと同じなのですが

インストールは、正常に終了するのですが
その後の、管理者IDでログインしようとしても、ログインできません。【ログイン情報が間違っています】とでます。

登録情報を
コピーペーストしても、間違えていると出るのですが
どうしたらよいですか?

うう〜ん。お困りですねー。経験がなくて想像だけなのですが。
原因として考えられるのは

・登録したID、パスワードと入力しているID、パスワードが違う
・IDやパスワードに特殊な文字(漢字とか?入るんでしたっけ?)を使っている

あたりなんですが、違うといっても分からないですよね。。。

phpmyadminなどのデータベースを見られる環境があるならば、xxxx_usersテーブルを表示して管理者のデータを更新することができます(xxxxというのはそれぞれのXOOPSで異なっていますので、usersで終わっているテーブル)。uid=1のデータが管理者のデータです。

まずはIDを確認したいのでuidが1のunameを確認します。パスワードの変更はphpmyadminの場合のやり方は修正画面でpassという項目に設定したいパスワードを入れます。そのとき注意して欲しいのは「関数」という欄で「MD5」を選んでおくということです。パスワードは暗号化したものが使われるので、これを選んでおけば普通にパスワードを入れても暗号化されて保存されます。


あとはー、ロストパスワードが使えると一番簡単ですね。

サイトのurl/lostpass.php

で登録したメールアドレスを入れると、パスワード再設定が出来ます。状況が再現できないのでこれができるかどうか分からないのですが…

お試しください♪
Powered by XOOPS CUBE LEGACY 2.1.X and RYUS